Подключение телефонов Cisco IPPhone к Cisco 1700 с Cisco Call Manager Express

10.02.2010

На основе базовой конфигурации моего стенда Cisco о котором я писал в предыдущей статье http://www.denaie.ru/?p=149, я создам небольшую PBX для работы ip телефонов Cisco IPPhone 7912, 7940 и используя карту FXS подключу к cisco обычные аналоговые телефоны.

Для того что бы иметь возможность использовать CCME необходимо иметь соответствующую поддержку этого сервиса в используемой  IOS.  У меня, к примеру, стоит IOS c1700-ipvoice-mz.123-11.T11.bin. Как видно из названия прошивки в ней есть поддержка ipvoice. Вообще для того чтобы узнать какие возможности (features) поддерживает ваша прошивка можно воспользоваться сервисом Cisco Features Navigator http://tools.cisco.com/ITDIT/CFN/ . Там по ссылке Search by Image  можно зная имя образа узнать  всю необходимую информацию.

Собственно подготовительная часть.  Для повторения моей конфигурации необходимо пара телефонов 7912, карта VIC 2-4 FXS и модуль PVDM для обработки аналогового телефона (если вы конечно будете использовать такие).

Телефоны подключаем в порты 5-6 на Switch 2950. На самой 2950 никаких настроек производить не нужно, если конфиг такой же, как в статье Маршртизатор на палочке. Если иначе необходимо на нужных портах прописать Vlan для IPPhone.

Карточку FXS и PVDM ставим в  соответствующие места. Аналоговый телефон втыкаем в порт 0 на карте FXS.

Для cisco 1700 будет следующий конфиг:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname gw1760-voip-test

!

voice-card 3

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip dhcp excluded-address 172.16.1.254

ip dhcp excluded-address 172.16.1.253

!

ip dhcp pool main

network 172.16.1.0 255.255.255.0

default-router 172.16.1.254

!

ip dhcp pool Phone

network 172.16.2.0 255.255.255.0

default-router 172.16.2.254

option 150 ip 172.16.2.254

!

!

no ip domain lookup

no ftp-server write-enable

!

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

codec preference 3 g711alaw

!

!

interface FastEthernet0/0

ip address 172.16.3.254 255.255.255.0

speed auto

full-duplex

!

interface FastEthernet0/0.100

encapsulation dot1Q 100

ip address 172.16.1.254 255.255.255.0

!

interface FastEthernet0/0.200

encapsulation dot1Q 200

ip address 172.16.2.254 255.255.255.0

!

ip classless

!

no ip http server

!

dialer-list 1 protocol ip permit

!

tftp-server flash:P00307020200.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
tftp-server flash:P0030702T023.sbn

!

control-plane

!

!

voice-port 3/0

cptone RU

!

voice-port 3/1

!

voice-port 3/2

!

voice-port 3/3

!

!

!

dial-peer voice 10 pots

preference 7

destination-pattern 733

port 3/0

!

telephony-service

load 7960-7940 P00307020200

max-ephones 10

max-dn 150

ip source-address 172.16.2.254 port 2000

time-format 24

date-format dd-mm-yy

timeouts ringing 60

system message TeSt Ip PhOnE

user-locale RU

create cnf-files version-stamp 7960 Jul 18 2006 12:38:44

max-conferences 4

call-forward pattern .T

moh music-on-hold.au

transfer-system full-consult

transfer-pattern .T

directory entry 1 711 name First Phone

directory entry 2 722 name Second Phone

directory entry 3 733 name Analogue Telephone

!

!

ephone-dn  1

number 711

pickup-group 1

label First Phone

description First Phone

name First Phone

preference 1

no huntstop

hold-alert 30 originator

!

!

ephone-dn  2

number 722

pickup-group 1

label Second Phone

description Second Phone

name Second Phone

preference 1

hold-alert 30 originator

!

!

ephone  1

mac-address 0011.BB66.DDE7

type 7912

button  1:1

!

!

!

ephone  2

mac-address 0012.D965.1FF5

type 7912

button  1:2

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

end

Соответственно в разделах Ephone  необходимо указывать MAC адреса  ваших телефонов для того что бы CCME выдал им номера. Параметр button  1:X очень важен. В нем осуществляется привязка Ephone к Ephone-dn и без него на линии не будет гудка.

В такой конфигурации прекрасно работают все три  телефона. Конечно конфиг абслютно сырой, базовый и в нем многое не настроено т.к. надо, но в дальнейшем мы дойдем и до этого. Следующим этапом будет подключение стенда к существующей Asterisk PBX и затем полная интеграция этих двух систем

Один комментарий

  • Makkcciim 27.10.2010 в 5:55 пп

    а если у меня используются аналоговые телефоны и передача голоса идет по Е1, то как тогда настроить CCME ?????

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *