Маршрутизатор на палочке – Router on a stick

10.02.2010

«Для Есипчука Михаила: Все в жизни происходит не просто так, для этого нужно работать»

В данной статье я напишу кое-какие аспекты настройки оборудования cisco для создания так называемого «маршрутизатора на палочке». Под данным термином понимается маршрутизатор который имеет в качестве интерфейса всего один порт и тем самым не имеющий возможности для подключения множества устройств. Для того что бы использовать этот маршрутизатор по назначению к нему необходим обыкновенный switch с поддержкой Vlan.

В итоге получается примерно такая конструкция

У меня в качестве стенда установлена Cisco 1700, у которой в случае отсутствия интерфейсных карт, есть всего 1 Ethernet порт и Cisco 2950 в качестве switch.

Между собой они соединены патчкордом по портам FastEthernet0/0 (cisco 1700) и GigabitEthernet0/1 (cisco 2950).

Теперь по конфигурации:

Cisco 1700

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname gw1700-voip-test

!

no aaa new-model

ip subnet-zero

ip cef

!

ip dhcp excluded-address 172.16.1.254

ip dhcp excluded-address 172.16.1.253

!

ip dhcp pool main

network 172.16.1.0 255.255.255.0

default-router 172.16.1.254

!

ip dhcp pool Phone

network 172.16.2.0 255.255.255.0

default-router 172.16.2.254

option 150 ip 172.16.2.254

!

no ip domain lookup

no ftp-server write-enable

!

interface FastEthernet0/0

ip address 172.16.3.254 255.255.255.0

speed auto

full-duplex

!

interface FastEthernet0/0.100

encapsulation dot1Q 100

ip address 172.16.1.254 255.255.255.0

!

interface FastEthernet0/0.200

encapsulation dot1Q 200

ip address 172.16.2.254 255.255.255.0

!

ip classless

!

no ip http server

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

end

Здесь собственно один нюанс, на интерфейсе FastEthernet0/0 создаем N сабинтерфейсов, по необходимому количеству подсетей и привязываем их к Vlan которые будут приходить от switch. В моем случае 2 vlan и для них созданы два DHCP пула (для рабочих станций и Cisco IPPhone).

Для cisco 2950:

sw-ex-2950#sh run

Building configuration…

Current configuration : 1996 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname sw-ex-2950

!

ip subnet-zero

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

vlan 100

name computers

!

vlan 200

name ipphone

!

interface FastEthernet0/1

switchport access vlan 100

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 100

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 100

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/4

switchport access vlan 100

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/5

switchport access vlan 200

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/6

switchport access vlan 200

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

description trunk-to-my-r00ter-on-a-stick

switchport mode trunk

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 172.16.3.253 255.255.255.0

no ip route-cache

shutdown

!

ip default-gateway 172.16.1.254

ip http server

!

line con 0

exec-timeout 0 0

line vty 0 4

password cisco

login

line vty 5 15

password cisco

login

!

!

End

Здесь все еще проще: GigabitEthernet0/1 определяем как транк, создаем два vlan и привязываем к интерфейсам.

Теперь компьютеры подключенные в порты  1-4 получают IP из диапазона 172.16.1.0, а ip телефоны подклчюенные в порты 5-6 из диапазона 172.16.2.0.

Вот такая незатейливая базовая конфигурация для моих опытов.

На основе ее затем создается телефония для cisco на CCME  и подключается Asterisk , о чем речь пойдет в следующей статье

3 комментария

  • Аноним 28.02.2010 в 1:58 дп

    Really good work about this website was done. Keep trying more — thanks!

  • Жанна д' арк 09.11.2012 в 1:48 дп

    У меня скоро тест а я незнаю ответы на простые вопросы такие как
    1. Какой командой можно сохранить изменения настройки СISCO маршрутизатора?
    2. Какой пример команды настройки IP адреса на интерфейсе маршрутизатора CISCO правильный?
    3. Какой командой программно выключается интерфейс на маршрутизаторе CISCO?
    4. Какой командой можно посматреть таблицу маршрутизации CISCO?
    5. Какой пример команды правильный для изменения имени маршрутизатора CISCO?
    6. Какой командой посмотреть содержимое flash накопителя CISCO?
    7. Какой командой можно посмотреть текущие настройки маршрутизатора CISCO?
    8. Какой пример команды верен для настройки интерфейса CISCO маршрутизатора?
    9. Какой пример команды верен для настройки статического маршрута в CISCO? маршрутизаторе?
    Если кто то знает ответы то напишите пожалуйста

    • Максим 24.11.2012 в 9:14 пп

      так у тут все на этот сайте есть. Список команд циско

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *